Format shortcuts not working with intl. keyboard lay-out

Dear Agenda Support team, Drew,

I’m a big fan of Agenda, using it a lot.

Allow me to share one issue I encounter that is quite annoying to me: Format shortcuts are not working with international keyboards input sources.

Note that my MacBook Pro has an Azerty keyboard, the standard lay-out for Belgium and France. It corresponds to following keyboard input sources (in settings): Belgian or French Numerical.

See more details of the complete tests I performed in the attached file

Looking forward to your reply (and fix),
Kind regards,

Testing the Agenda short keys.pdf (134.9 KB)
Testing the Agenda short keys.agenda (4.0 KB)

Ugh. Very odd. Especially since keyboard shortcuts are nearly completely handled by the OS itself.

Could it be that the ones that are note working correspond to shortcuts for another app or system functionality? Perhaps you can check in the System Preferences. I believe the Keyboard section there has a list.

The fact that Minor heading does work, and Heading doesn’t, even though the modifiers are the same, suggests to me the issue is more likely overloaded shortcuts, not the modifiers themselves.

It is perhaps worth restarting the app too. Maybe it is just in a strange corrupted state.

Kind regards,


Same problem over here with an AZERTY keyboard too :wink:

Have you been able to find out what exactly doesn’t work and why? Are the shortcuts we chose being used for something else? Or are the characters being treated differently?


I’ve the exact same problem and the same configuration than @jfcahay
Unfortunately I can upload attachments.

When I type : Ctrl + Cmd + 2 then it seems that it triggers the “View Menu” instead of the “Format Menu”.
Like if I had simply type “Cmd + 2”.

However Ctrl + Cmd + 3, Ctrl + Cmd + 4 etc are working as expected.

The only problems are present with shortcuts which are also present in the “View Menu”.
Ctrl + Cmd + 1 vs. Cmd + 1
Ctrl + Cmd + 2 vs. Cmd + 2


apologies for not having followed-up, I have been quite busy.

The issue is still not resolved.

** 1)
Are the shortcuts we chose being used for something else?:**

No, I checked but no other applications are using these shortcuts, al least not that I can see in System preferences > Keyboard > Shortcuts.

tried to create my own application shortcuts for Agenda in System
preferences > Keyboard > Shortcuts.

my keyboard, the Key “2” is “é” when not in uppercase. When done for Style>Sub-Heading it seems to be updated in the Agenda app (see image). But still it doesn’t work as it should.

I try the same procedure to update the shortcut for indentation>Increase, it does not appear in Agenda, not does it work.

** 2)
Or are the characters being treated differently?**

behaviour looks really inconsistent in my eyes, some shortcuts do work and some other don’t:

Style, only Minor Heading, Minor Sub-Heading and Preformatted work, but not the fist three.

Indentation, my keyboard does not have the square parenthesis signs [ ] . Using
the corresponding keys (same location) does not work.

don’t know how difficult it would be, but ideally, one would have the possibility to define his own shortcuts within the settings of the Agenda application.

I guess we will have to try to get one of these keyboards to test it. I’m not sure what could be going on, because we don’t do anything special AFAIK. We are just doing the usual shortcut approach that every developer uses. Perhaps something specific about the shortcuts we have chosen.