Errors with Finder Links

Whenever I try to use links to local files I get the following Error.
I would be grateful if someone could help me out.

Hi -
which version of Agenda you are using?
What is your version of MacOS?

Sorry for the late answer.

I am using the new beta version of the app. (Both Beta and Non-Beta cause the same issue)

Using version: 10.15.6 (19G2021)

What was the file type that it linked? Is the application for that type of file working properly?

The file type seems not to matter too much.
I have tried it with the following files, with the same result:
docx
pdf (Adobe Acrobat and Preview)
rtx
folders (in finder)
pptx
tex

The only thing that seems to work is linking a file in finder. Then it open finder at the right location. As soon as I want an app to open there seems to be an error…

Can you explain how you are making the links? Are you creating a link, or putting the file in as an attachment?

A screenshot of one of them might help explain.

When I use the Control + Drag, it opens the file in finder. That works just fine.

using the “Copy as Pathname” and adding at as a link (with cmd+k) and pasting the link does not work, since it opens the file in the app, not just in finder.

Yes, pathname is not really a link. To get a link, drag in the file and hold down the CTRL key as you drop.

Note you could also experiment with the Share menu there. You may be able to share into Agenda in a useful way.

In short, copying the pathname is not the way to go. If you drag the attachment in to Agenda, you get a green box, and a copy of the attachment is actually stored by Agenda and synced. If you just want a link to Finder, hold CTRL as you drop the file.

Kind regards,
Drew