Dropbox Sync Stopped Working

What I did: Added some new Projects/Notes on Agenda on OS X

What happened: I see the files picked up in Dropbox on both my OS X device and iOS Device

What I expected: The same Projects/Notes to appear on Agenda for mobile. They did not. I actually attached an excel file to one of the notes and verified that was in the dropbox (you don’t seem to encrypt attached files), so I know dropbox has the most recent data.

Things that might be helpful to know (Agenda version, OS and model, etc):

Macbook Pro, Amazon Corporate OS X restricted (hence dropbox) Big Sur 11.6.2, Agenda version 13.1.1
iPhone 13, OS: 15.1.1 Agenda Version 13.1.3

Do you see any data sync over at all?

Do you mean you can see files being added to Dropbox on your Mac?

Usually, this is simply a case of giving the device enough time to upload/download the data. You could hold Agenda in the foreground for a while, just stopping your device from going to sleep, to give it time. If you don’t want to to have to constantly keep the device from “sleeping”, you can turn off the Autolock in the Settings.

Repeat this on each device, letting it sync for around 20 minutes. Usually that will allow everything to upload and download, and it will be fast after that.

Note that you can see if it is syncing by looking for the cloud icon at the bottom of the right panel. It appears when there is sync activity.

Let me know if this doesn’t help.

The OS X application seems to correctly add data to dropbox, yes. And I can observe Dropbox correctly syncing across devices. The issues seems to be the iOS application not picking up the changes. I’ve allowed the mobile app to run in the foreground and see no changes.

Note: I do not see any cloud sync symbol on mobile.

OK, let’s assume the Mac is working fine then and focus on iOS.

Assuming the Mac has all the data, can you try simply deleting the iOS app completely, and then installing it again via the App Store? That will remove all the data on the device.

Then turn on the Dropbox sync in the settings of the iOS app (right panel, bottom left button). When you do that, it should take you to a web browser to sign in. Double check that the account you are signing in to in Dropbox is the same as on the Mac.

Let me know how it goes.

Kind regards,
Drew

Unfortunately, this did not work.

I deleted the app and reinstalled and signed in and the same lacking notes are missing.

Note as a sanity check I installed and signed in on an iPad and it synced everything successfully. This increased my confidence it isn’t Dropbox.

Next troubleshooting idea?

So you signed in on a new device, an iPad, and it synced up beautifully? But when signing in on the original iOS device, it fails? And deleting the app entirely from that problem device, and installing again from the App Store did not help?

You said it doesn’t sync anything at all, right? Ie you see no data appear on that iOS device, right?

Does that device have the latest Agenda installed? What about a recent iOS operating system?

When you start the Dropbox sync, does it take you to a separate browser window to sign in? And when you sign in, do you tap the button to go back to Agenda? (Ie you shouldn’t just switch back yourself. You need to tap the button in the browser to go back.)

The fact that an iPad works says to me the Mac is working, and the data is in Dropbox. And the iPad is running the same software as iPhone, so they should behave virtually the same.

Drew

I’m not sure why it wasn’t working before. I had iOS fully up to date.

I deleted both agenda and Dropbox this time. Restarted the device. Then redownloaded and it worked as expected this time.

I’m not sure when I selected Dropbox as the sync option before it prompted me for permission. Perhaps that’s a setting that was saved somewhere on the device only reset when I deleted Dropbox and it’s data?

There are still some quirks I don’t understand. For example, when I delete Agenda and it’s data, then redownload, I’m somehow auto-signed-in to my agenda account when I first open it. Like I go to account and it shows me signed in. How is this possible when I choose to delete the data from iCloud?

Glad the sync is working for you.

The sign in is explained by the fact that we put your sign in credentials in the iCloud Keychain. That is a secure place to put them, shared between devices. So even removing the app leaves that, because it is used on other devices.

Kind regards,
Drew

A post was split to a new topic: Dropbox Sync problem

Hey Drew, so I’ve been trying to solve this issue on my own for weeks and I’m about to give up on Agenda altogether.

My most recent trial was a complete deletion of all my past notes in one final effort to just get it to sync consistently.

I’ve tried deleting on each iOS, iPad OS, and macOS my entire Dropbox contents, all agenda data, and each of the 6 applications. Reinstalled all fresh, signed in to Dropbox on each platform. Then setup Agenda & set Dropbox refresh. I added a category/project/note and it synced. I took a deep breath and then left it for a week.

A few days ago, i tried to add a new category/project/note on my phone and it did not sync (still has not synced) to iPad or Mac. I’ve verified that files were added to Dropbox and I see that there are literally hundreds of “settings” and “systems” files created from a very simple category/project/note addition. I’ve been able to verify that those new files were synced on Dropbox on all three platforms.

At this point, when I open iPad or Mac Agenda apps, it shows the ‘cloud download’ icon in seeming perpetuity, certainly for a length of an hour+ on my Mac. And yet it never surfaces the newly added category/project/note that was added on my phone.

Please for the love of God tell me there’s something you can do because I love agenda but this has made me want to break my devices

You are not on the Agenda 14 beta, correct?

If not, I have good news. Agenda 14 will be here on Tuesday, and it has a lot of sync fixes. I’m hopeful it will fix your issues.

When Agenda 14 comes out, can you update your devices and see if that helps? The first sync can still take a while, but it should finish. We have fixed a number of bugs that could cause it to stall.

Let me know how it goes.
Kind regards,
Drew

1 Like

I am not, but wow this is great news. I think I will again wipe the Agenda data from dropbox and delete Agenda on all my devices; I’ll do a fresh install Tuesday/Wednesday and be praying it works.

I want to say how awesome Agenda is and as an SDM at Amazon, I’m very impressed at your responsiveness to customers and development velocity for such a small team. Seriously, kudos to you!

2 Likes

Thanks for the support! Appreciate that.

Let us know if the problems persist after Agenda 14 is out. We want to squash any sync bugs that arise.

Kind regards,
Drew

I got a new Mac, so I installed Dropbox, let it sync, then installed Agenda.

It imported the notes but not the category structure correctly.

I figured I would try again.

  1. I turned off sync and did NOT delete the Dropbox data.
  2. I delete the notes that were left in Agenda
  3. I restarted my machine
  4. I set Dropbox sync again
  5. It proceeded to delete all my files in Dropbox rather than repopulating from Dropbox itself.

So, now twice I’ve lost all my notes on Agenda, and I think I can’t give it another chance.

Best of luck. I’ll reply back if you have questions but I’m deleting it everywhere. It’s too frustrating for me to even look at Agenda again.

Ugh, I’m really sorry to hear that.

How did you delete your data? Did you drag your projects to the trash, and empty the trash? If you do that, it will permanently remove your data. Even if sync is turned off, the fact that you deleted the projects is stored, and when you later turn on sync, it will go to remove those projects on other devices. It’s the same as if you drag a file to trash on your Mac. If you have iCloud sync on, it will disappear on all your devices.

It is possible to delete the data and repopulate from the cloud, but you would have to delete the data directly, in Finder, not by dragging projects to the trash in the app.

If you have a time machine backup, or some other backup, we could probably get the data back. Let me know if you want to try that.

So, I missed Agenda a lot. I really, really want Agenda to work for me, as I can’ t find any other app that:

  • allows handwriting & text notes on iPad
  • can sync w/o iCloud as I need it to sync to my work laptop

But as soon as I tried, I ran into another sync issue.

  1. I created a new Project with a single note that had a table with some info, all on my iPad.
  2. I see file updates in Dropbox coinciding with the time of this addition
  3. I see the Dropbox correctly sync to my Mac
  4. A project appears on the macOS Agenda entitled “Untitled” with no notes in it.

Is there a way to “force re-sync” from Dropbox? With all my issues, it seems like Dropbox has what is expected but one Agenda application on one of my devices will not or cannot pull the projects/notes correctly.

I’ve observed the “Download Cloud Sync Symbol” on my macOS Agenda application for about 30 minutes now. It keeps appearing and nothing changes in terms of the Projects/Notes updating/appearing.

If the symbol is still blinking it means it’s still syncing. After updating to Agenda 14 there’s a lot of migration data generated that needs to be synced, which means the sync can have quite a backlog. I would suggest to still give it some more time, unfortunately Dropbox is slower to sync than iCloud. Make sure the devices stay in the foreground and don’t go to sleep and sync should normally catch up in the end and the indicator should stop blinking. Let us know if this is not the case.