Dropbox not syncing all changes

What I did: I created a new project and moved some notes there from another project in the same category

What happened: The new project is only visable on the computer I created it on (MacBook Pro). The notes are still in the old project on my iphone and iMac at work.

What I expected: That the project should appear on all my devices and the notes been moved.

Things that might be helpful to know (Agenda version, OS and model, etc): MacBook Pro and iMac both run MacOS Monterey and Agenda 16 (259). iPhone 12 with ios 16.2

I have also created a note on my Laptop that is not fully synced to my other devices. It´s been a couple of days since the change and all the apps have been open for a while to complete the sync.



Note on Macbook pro

Note on iMac

Do you see clouds moving over the islands logo top right in your Mac window? What about in the right panel at the bottom on iOS/iPadOS?

These clouds indicate ongoing syncing. If you see them, it’s an idea to prevent the device from sleeping (turn off autolock on iOS/Prevent sleep on Mac). If you do that for 30 minutes, usually things will sync up.

If that doesn’t work, try turning off the sync in Agenda for each device (don’t remove the cloud data though). Then turn it to Dropbox again. It should ask you to sign in. Make sure you go through the full sign in until you go back to Agenda from the browser.


Thanks for the reply.

All the apps has been open for more than 30 minutes and there are no moving clouds. I’ve seen the cloud move and then stop on all my devices so the sync “should” be done.

I’ll try to turn off and on sync and see it that’s help.

I´ve now done some testing.

I turned off sync on all devices and turned on Dropbox one by one. I let the devices complete the sync before adding sync to the next one.

After this I still had the same issue, so I did some more testing.

I finally realized that it´s only my laptop that has issues. If I change a note, create a project, delete or add a tag, nothing syncs to the other devices. But if I do the same in my iPhone or iMac I get an alomost instant sync.

What do I do to solve this?

I have some notes on my laptop that isn´t synced to the other devices, any way to reinstall Agenda without loosing them?

Is there anyway to see if I have the version from AppStore or website?

Choose Agenda > About Agenda

Depending on how many notes you have that are not synced, you could export them as Agenda files, and import them on the other devices. If that succeeds, you could then remove the data from the problem device and start over. Only do that if you are sure all your data is on the other devices.

If you want to delete the Agenda data, you would have to do the following:

  1. Quit Agenda if it is running
  2. Click on Finder, choose Go > Go to Folder, and enter ~/Library/Group Containers. Delete the folder WRBK2Z2EG7.group.com.momenta.agenda.macos
  3. Click on Finder, choose Go > Go to Folder, and enter ~/Library/Containers. Delete the folder com.momenta.agenda.macos or Agenda if you see one.


I have finally had time to do as the instructions above.

  1. I didnt found com.momento.agenda…

But I deleted the first folder and everything dissapeard from Agenda on my Laptop.

So far so good.

I started the sync and let it run for about 30 min, the last 10 minutes without moving clouds.

This is what I got after the sync.

iMac at work

Laptop at home

Not close to everything is synced. Some projects are synced but in the wrong category. A lot of notes are missing, some notes are missing the title and some are missing content inside the note.

For me it looks like Dropbox is the issue here.
Is there anyway I can reset the sync data and upload it again from my iMac at work?

If you iMac at work has all the data, you could indeed try resetting.

  1. Turn off Dropbox sync on each device, and when asked, remove the data
  2. Go into Dropbox on a Mac, and into the Apps folder. Remove the Agenda folder there to the Trash.
  3. Wait 20 minutes to let Dropbox sync up
  4. Turn on the sync in Agenda on the work Mac to Dropbox, sign in, and wait for upload to finish
  5. Turn on sync on another device.
  6. Repeat

Kind regards,

Hi again,

I did that with no luck. All things still doesnt sync.
It may depend on that I dont have the dropbox app installed. I use my private dropbox account and can only be logged in on 3 devices.

So I decided to try iCloud and only sync my work computers via my AppleID for work.

  1. I disabled sync on all devices and removed the data.
  2. I deleted the app and all data on my laptop and reinstalled a fresh version from App Store.
  3. I turned on iCloud sync on my work computer and let it run over night.
  4. The next day I opened Agenda on my laptop and turned in iCloud sync.
  5. Still only part of the content is synced, This time even less then before.

It seems to me that my iMac at work doesnt send all the data to either dropbox nor iCloud.

What the next step now?

Dropbox does require the app on iOS, in order to sign in. Without that, I don’t think it will be able to download any data.

iCloud should certainly work. You need to be using the same Apple ID on each device, and have iCloud Drive. turned on.

On the Mac, you can see if it is finished syncing by looking at the clouds going over the islands top right. As long as that is happening, it is still busy.

Same goes for the iMac with all the data. Make sure you let it run until the clouds stop going over.

BTW, Are you sure that notes are missing? Could the problem be that the sidebar is messed up, but that all data is present? There was an issue some time ago where it was possible the sidebar could get messed up, but that all data was present. If that is the case, best to drag the projects into the right locations. Should work fine going forward, because the bug has been fixed. (You should make sure you have the latest version on all devices: 16.1)

Thank for the reply.

No moving clouds and all data is definitely not there with iCloud. I’ll have to do some troubleshooting and see if I can solve it.

Try clearing the iCloud data the same way you did with Dropbox. Ie turn off sync on each device, and tell into remove the cloud data. Then add one device at a time, letting each one upload for 30 mins or so.

If that doesn’t work, we have one more drastic reset. This involves clearing the data on all devices except one Mac (which must have all the data). If you want to try that, this is how you can do it.

  1. Turn off sync in Agenda on each device, removing the cloud data each time it asks you if you want to remove it.
  2. Delete the app on your iOS devices. Only do this if you know your Mac has all the data, because deleting your iOS apps also deletes their copy of the Agenda data.
  3. Quit the Mac app
  4. Click on Finder, and choose Go > Go to Folder
  5. Enter this ~/Library/Group Containers/WRBK2Z2EG7.group.com.momenta.agenda.macos/Release/Application (There is one space after Group, but no other spaces)
  6. You should see folders DerivedInfo, PersistentInfo etc
  7. Drag the DerivedInfo to the Trash
  8. Go into PersistentInfo, and drag any files beginning with “ChangeSets” to the Trash too
  9. Launch Agenda on Mac, and wait for your data to rebuild (a minute or two)
  10. Once you see all your data again, turn on the sync. I recommend iCloud, but Dropbox should also work.
  11. Wait 10 minutes with Agenda just running, and the computer staying awake
  12. Now install on iOS, and enable the sync there too. Again, keep it awake about 10 minutes.

I finally managed to get it to work. It seems that there was some sort of corruption in the database on my iMac, that resulted in some notes not being synced. Didn´t matter if I used dropbox or iCloud.

This is how I got it to work again:

  1. Deleted all data on Dropbox, both via Agenda and manually.

  2. Deleted all data on my laptop and installed a clean version of Agenda.

  3. Exported all my categories as Agenda files from iMac

  4. Imported these agenda files on my Laptop.

  5. Deleted the duplicates that occurred on iMac after first sync.


Ugh. Glad you sorted it out, but sorry you had to go through all that.