Dragging to select dates

This is an odd one.

Last night, I upgraded to Ventura and this problem started after that.

What I did:

  • clicked on the calendar for a note to change the note’s date
  • dragged over some dates to select a week

What happened:

  • it only selected Tuesday and Wednesday of that week

What I expected:

  • to select Sunday thru Saturday

Things that might be helpful to know (Agenda version, OS and model, etc):

  • Mac OS Ventura 13.0
  • Agenda Version 16.0 (259)
  • dragging works fine to select text, drag windows, etc, both in and out of Agenda
  • I use drag lock, normally; I tried this with normal drag with the same result

Work around:

  • to select a range of dates, click on the start date and then click on the end date while holding down the shift key

Does it help if you quit and restart Agenda? I wonder whether it had to do with the change of the hour (summer/winter time)

That fixed it! But it wouldn’t be due to summer/winter time change; in the US, we don’t shift to winter time until next Sunday — we started shifting after Halloween instead of just before.


Hmm, very odd then, but glad that fixed it!

1 Like