Deleted Tags Show up in the Search

What I did: I track my items with a #todo tag. After completing the work, I delete the #todo tag from the specific note. But when I search the #todo tag in the “Search All”

What happened: The notes not containing the #todo tag also show up. These notes previously had the #todo tags.

What I expected: Only notes with #todo tags to show up


Things that might be helpful to know (Agenda version, OS and model, etc): V5.0

Is this a short lived problem, or does it continue into the future? The search index can take a little bit to update. Could it just be that you are seeing that delay? If you wait 5 minutes, and start a new search, is the same problem there? What about restarting the app?

Not a short-lived problem.

Blockquote
f you wait 5 minutes, and start a new search, is the same problem there?

Yes. So, I’m seeing all the notes since I started using Agenda (wherein I used the #todo tag)

Blockquote
What about restarting the app?

Tried it now - But didn’t solve the issue.

Am I “searching” it wrong?

No, sounds like your searches are fine. This must be an issue in the app. We will investigate.

A few things to check:

  • Are you on our latest version of the app?
  • If you add a new note with #todo, does it appear in the search?
  • If you locate a small note that is still appearing in the search when it shouldn’t, and you make a small edit to each paragraph that used to have a #todo tag (eg put in a space at the end), does it get removed from the search after you search again 10 seconds later?

I’m not sure what happened, but the issue seems to have got corrected.

Are you on our latest version of the app?

Yes. The app did get updated sometime last week

If you add a new note with #todo, does it appear in the search?

Yes. This works seamlessly

small edit to each paragraph that used to have a #todo tag (eg put in a space at the end), does it get removed from the search

When I had tried before, it didn’t

But now, I tried to replicate the issue with a #test tag, but I couldn’t replicate the issue. The issue “sort of” still persisted with #todo. Then I added the #todo tag to the notes which were coming up in the search, and then deleted the tag again. Its no longer coming up in the Search list.

In short - Not facing the issue now.
Apologies for this, but I was really facing the issue. Maybe for the notes created under the previous version of Agenda. Thanks for the help though.

P.S: I love Agenda. It seems the first viable solution for me to switch from a physical notebook to Mac.

1 Like

Great to hear it is working again. Sounds like a short term glitch of some sort. Restarting the app may help if you see it again.

Let us know if it starts to reoccur.

Drew

1 Like