Can’t integrate with Calendar app

calendar

#1

I clicked on the “Connect to Calendar” button, the privacy tab in system preferences opened, with privacy>accesibility open. Agenda was not in the list. The Calendar list under privacy is also empty. I added Agenda to accesibilty manually but that didn’t integrate it either.

Things that might be helpful to know (Agenda version, OS and model, etc):
Agenda 2.0, macOS 10.13.3


#2

If you open the sidebar under the View menu, do you have to give Agenda permission to connect to your Calendar? If so, clicking on Connect to Calendar should also make them show in the preferences.


#3

Yes, but when I click Connect to Calendar, it just takes me to system preferences without Agenda appearing there.


#4

Is there any other way to give permission? e.g. command line?


#5

Try the following:

  • quit Agenda

  • in the Terminal.app enter:

tccutil reset Calendar

When you now start Agenda and click the connect to calendar button it should ask permission again.


#6

I am getting

tccutil: Failed to reset database

and no change when I try to connect it again


#7

Does a reboot of your Mac, followed by the command work? If not, can you try

sudo tccutil reset Calendar

You will then need to enter your password. Let me know if that helps.


#8

Yup tried that previously but same error message unfortunately


#9

Actually it suddenly worked, after making no additional changes, so I guess that will remain a mystery. Thanks for the help


#10

Pfew, glad to hear, not that many options left :slight_smile:


split this topic #11

A post was split to a new topic: Manual and calendar features