Calendar not Updating until I quit the app

What I did:
When I have agenda open and add a new calendar event from the stock calendar app, or accept meeting invites I would like to create a note linked to it, but the calendar events in the agenda app do not update.

What happened:
If agenda is open while adding new calendar events elswhere the calendar events don’t show up in agenda until I quit and restart the app.

What I expected:
When there is an event update in one of the calendar sources the app refreshes the events within its calendar too.

Things that might be helpful to know (Agenda version, OS and model, etc):
latest agenda version.
macos 12.6

1 Like

Odd, I just wanted to make sure we hadn’t missed anything but it works fine here. What calendars are you using (iCloud, Exchange, Google Calendar)? And you’re not using a third party calendar tool? Does it help if you quit Agenda and then in the System Preferences under Privacy disable and enable again Agenda’s permission to access your calendar?

I am using, icloud, gmail and exchange. The same issue is present for all calendar types. I’ve tried the permission off and on it didn’t make a difference.
I am using the built in calendar app within macos. When I add new event in the calendar (be that icloud, gmail, or exchange), agenda only sees the event once I restart the app.

Does it help if you:

  • quit Agenda
  • in Go to Folder under the Go menu in Finder, paste:
    ~/Library/Group Containers/
  • make a backup copy of the CachedInfo folder, then delete it
  • start Agenda

Do things works as they should after that?

Tried it, it doesn’t solve the issue. The same thing works fine on ios and ipad.

same issue for me. calendar in agenga only updates following quit/reopen cycle

I am experiencing the same problem.
Tried the offered solution and nothing changed.

Are you all on macOS12?

Yes, I am on 12.6

Yes, 12.6

Hi there!

Just wanted to see if there was an update on this as it’s still a problem

Unfortunately no update yet, it seems to be an issue with Apple’s calendar system on the affected devices I’m afraid.

It seems to have solved itself on my end. about a week ago on macos 12.6. I’ve updated to macos 13 now and it seems to working ok too.

Ah great to hear that!