Bug with x-callback template?

What I did:
agenda://x-callback-url/create-note?project-title=Inbox&template-name=\date(format: dd-MMM-yy) - Journal

What happened:
Note created but title missing " - Journal" after the date. No issue when choose template on Agenda, a note would be created properly. Could be related to x-callback?

What I expected:
Expected " - Journal" to be includd after the date as per template

Things that might be helpful to know (Agenda version, OS and model, etc):
Agenda 13.11
Mac Big Sur
Macbook M1

Hmm, more in @mekentosj’s area, but have you tried percent escaping it?

Eg. using https://www.url-encode-decode.com

Will give this:

This might work. I think the issue is probably the spaces you have in there. Not allowed in URLs

Didn’t work. Even tried simpler way by removing spaces in template but didn’t work too. Title only shows date without “-Journal”

agenda://x-callback-url/create-note?project-title=Inbox&template-name=\date(format: dd-MMM-yy)-Journal

Ok, figured things out but logic flow might need updating.

Because “Assign New Notes to Today” was check therefore title will always have Today’s date as title overwriting Title of template IF call via x-callback. IF user chooses template while on Agenda, title reflects correctly: title of template overwrites today’s date in title and note is still assgiend to today’s date. Sounds like it’s a logic flow of Agenda when it comes to x-callback - Agenda should assing date after title is populated as per template.

Drew, any feedback on this bug?

We are looking into it. May not be a trivial fix. You are probably best to avoid the problem for now. Sorry.

Hello. Not a poster on forums but this is massive bug & want you to know. Automating me workflows, 1 of many complex scripts didn’t work on agenda & could not work out why until discovered this thread. Using 2 devices, multiple scripts to automate & often titles didn’t show up as expected. This thread exposed this bug with 1 device having today’s date enabled that always overwrite templates titles. Had to stop using me script - drove me crazy going thru scripts finding where issue was & turned out it is agenda problem. Do fix this bug. TQ.

It is in the list. We will be investigating what is going on.