Apple Notes Import fail

import

#1

What I did: Created a new project. Imported Apple Notes

What happened: I got nada, zilch, zero notes. There is now one Untitled empty note. hmmm

What I expected: Well, imported notes

Things that might be helpful to know (Agenda version, OS and model, etc):

    all software up to date including Agenda from 2 days ago.

Apple Notes import fail - update
#2

followup to the Apple Notes import fail

What I did: imported notes

What happened: apparently they imported, but category/project column did not update. I then deleted all the sample projects, that was fine. When I deleted the Sample category itself it didn’t happen. The dialog stayed open, but I was able to quit the app.
When restarted the sample category was gone and the imported notes appeared (twice in fact, since I tried again when I didn’t see any changes).

What I expected: after import should have shown the new imports.

Things that might be helpful to know (Agenda version, OS and model, etc):


#3

Sounds like Agenda run into some internal problem at an earlier stage and that the restart solved that, we’ll investigate to see what could have caused this. Thanks for reporting!


#4

yeah someone suggested I had the category closed, but no there was nothing new over there. thanks


#5

Yes I bought Agenda yesterday but can’t import Apple Notes…it goes for a little while then freezes… I think I must have too many Apple Notes… Pity though !!!

Rees


#7

Are you sure it is frozen? The new Mojave should ask if it can access notes, and this will block the import until you answer that it can do that. So look for a floating dialog from the operating system.

If you downloaded the app from our web site, rather than from the Mac App Store, there is a problem with this request, and it doesn’t work. We have a fix coming, but in the meantime, you could use the Mac App Store version.

Kind regards,
Drew


#8

Thanks for you help I will look into this. The green importing bar went to about 1/5 th of the way and went no further. But I will try again.

In Pacē
Richard G


#9

Any update on that subject?
Same problem for me : the import process is started but freezzes after 20%. The process is using al available memory then Agenda stops…


#10

We did make some improvements. Do you have the latest 2.6 version?


#11

yes. Same problem


#12

Are you sure it isn’t just a question of waiting? Does the app crash, or just seem to stall? My guess is that a stall is simply a long import which will eventually finish.


#13

I have had a look, and a fix for this would not be trivial. I guess you just have too much data for the way we are importing. We need to update the import approach to get this lower, I’m afraid.


#14

ok. is there any way to select just a subset of my notes?


#15

No, I’m afraid not. That would indeed be a solution, but it isn’t yet possible.

I’m not sure if Apple Notes can export the files for you somehow. Maybe that is a way to move some over.


#16

I found a way: I exported osx notes in markdown files with an
app named « Exporter »
Then no more problem to import these files into Agenda


#17

Great! Glad you found a way. It may well be that all the problems come from AppleScript, which is what we have to use to access Notes. We will investigate, but it is good to know there is a workaround.