App for Mac not updating

What I did: Trying to update Mac App

What happened: Won’t update

What I expected: Update completion

Things that might be helpful to know (Agenda version, OS and model, etc): Latest version Agenda, MAC OS Big Sur latest version

I have experienced the same yesterday. Today in the morning the updated completed successfully. I have observed this with other apps updates as well. I guess you’ll just have to retry it from time to time. Very annoying though…

1 Like

After around two full days and 50 to 100 manual attempts it had still not updated. Only Agenda, the other updates came one after one and got updated without problem. At last I got, may I say?, pissed off and instead deleted Agenda and reinstalled it. When it was a download and not an update, it suddenly worked out. Strange. In this context I’d like to thank @mekentosj again for mentioning that I could download the update from Agenda’s website. But, really, Apple ought to do something about this behaviour. They do not, for obvious reasons, offer the direct contact with the staff as we Agenda users are fortunate enough to enjoy.

1 Like

You’re welcome @joobo, it’s indeed very frustrating, not sure why this happens, it also happened for a number of users with the last update. As @joobo states, the workaround is to download the update from agenda.com, or as @jander confirmed, keep trying until it does work.

Still not working some dates on

We see people who report it resolving within hours, others within days, no real pattern. Perhaps worth restarting your Mac to see if it helps, and otherwise probably just easier to download the app from agenda.com

Thanks have done this now. So presumably I can now just check for updates manually (or once alerted by email) and do it via the app itself and avoid the App Store?

I got similar reports for users of my app and there seem to currently be several problems on the Mac App Store where downloads are stalled and do not continue, especially under macOS Mojave. The following steps might turn things back to normal:

  1. Open the App Store app
  2. Open Activity Monitor
  3. Look for appstoreagent in Activity Monitor and force-quit the process.

Now the download should proceed.

3 Likes

Ah brilliant to know, thanks for sharing!