An “update / sync” option to force calendar sync

How do I get Agenda to re-sync with my calendar? I just added a new meeting (for today), and took a few notes. The meeting is not showing up in Agenda, so I can’t link the note to the meeting. It’s been an hour since I created hte meeting… even tried quitting/restarting Agenda… but the new meeting is just not showing up in the Agenda calendar view… :confused:

Can you send some screenshots of the event? If you are using the 2.0 beta, are you sure you have the calendar enabled in the preferences? What version are you using? Was the event created in or a 3rd party app? On the same machine as agenda?

I’m using Fantastical (which is where the event was created). I’m using the latest version available from the App Store as of today, version 1.4 (not a beta). All on the same machine. Also, when I open my calendar in either Google Calendar or the Mac Calendar app, the meeting does appear there, correctly. It’s just not updating in Agenda.

The issue will probably be fixed in the 2.0 currently in beta, due out later this week if everything goes well.

Is anyone else still having this issue with calendar entries taking a long time to sync to agenda? I am using version 2.6 (which I love btw) but my one pet peeve is that I create a new meeting and would like to start making notes related to the meeting and it takes hours or sometimes until the next day before it appears in Agenda. Would love it if there was a way to force the sync. Process.

Once the attachment feature is out (soon) we’ll dive into a number of performance improvements, among which the calendar integration. Stay tuned!

Great news-thanks

Just a note that this is still an issue. I added an appointment to my calendar for Thursday (two days from now). I’ve been trying to get Agenda to update and show the new meeting for about an hour. Including quitting Agenda and starting it again.

FINALLY, after tinkering for 1+ hours, it just showed up all by itself. (I was doing something else, looked at Agenda… and hocus pocus, the meeting was visible).

VERY frustrating. Everything else (Fantasticial, my Apple Watch, other apps) update withing seconds of adding the new appointment.

We hear you, and as said, this is next on our list to target. Many thanks for your patience, we hope to have a solution soon.

How can I force sync? My iOS + Desktop apps have not been synced this week at all and it’s driving me crazy - nothing seems to trigger it

Any chance you ran out of iCloud space?

A post was split to a new topic: Sync between two macs

I know this isn’t the ideal solution, but I’ve been using keyboard maestro to close agenda and then reopen it with a keyboard shortcut. This forces the resync for me.

I had to go back and look at my shortcut, and what I realized is that I am restarting the default mac calendar app, not the Agenda application. I just have it under my Agenda scripts.

My setup
I use Google calendar as the back end, but primarily use Fantastical 2 to make my entries. Agenda syncs with the default Mac Calendar application, so I have to make sure that app pulls in from Google.

Yes, was having the same issues, and found out it was that my native mac calendar app was not updating in time. I changed the refresh settings in the calendar app for my different google accounts (under Preferences > Accounts) from 15 min to 1 min, and now Agenda updates the its calendar within the 1 min time frame. :slightly_smiling_face:

1 Like

Ah, great tip, hadn’t thought about that one!