Agenda won't restart after crash

crash

#1

What I did:

Not really 100% sure. I was scrolling through a collection of notes, and got the crash.

What happened:

I attempted to restart. The Agenda Icon in the Dock bounced but I never got a window. The Dock and activity monitor say “Not responding”

What I expected:

For Agenda to launch, optionally with the bug reporter window.

THis is concerning that the work I’ve put into Agenda is not accessible.

Things that might be helpful to know (Agenda version, OS and model, etc):

1.3 beta, mac 10.12.6


#2

Seems to fail here?


#3

Hmm, that’s odd and indeed nasty. Almost sounds like a sandbox issue. Does it help if you reboot your Mac? If not, does it help if you quit Agenda and delete its preferences by entering in the terminal:

defaults delete com.momenta.agenda.macos


#4

Btw, any chance you could dig up the crash report from the library and send it to us?


#5

If you tell me where to look …


#6

If you use terminal again and type:

open ~/Library/Containers/com.momenta.agenda.macos/Data/Library/Application\ Support/CrashReporter

are there any Agenda crashes?


#7

The reboot worked and the bug reporter window came up

You should have the crash report now. There is a plist in that directory if you want it.


#8

The reboot worked and the bug reporter window came up

Pfew, very happy to hear that. I did some googling and indeed it does sounds like the crash caused the XPC process not to give back access to the sandbox. The restart was probably necessary to reset things back to how it should. Thanks also for the crash report, we’ll investigate.


#9

the plist is:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>Date</key>
	<date>2018-02-05T21:02:25Z</date>
	<key>ForceQuitDate</key>
	<date>2018-02-05T21:15:53Z</date>
	<key>Path</key>
	<string>/Users/jgraham/Library/Logs/DiagnosticReports/Agenda_2018-02-05-160236_jgraham.crash</string>
</dict>
</plist>

Not really interesting

Thanks for the help!


#10

Cheers @jim, perhaps the uploaded Diagnostic report tells us more, will check.