"Agenda Insertion Point" Breaking URL

Using latest Agenda version on macOS.

I recently noticed some strange behaviour with link formatting. When a link is changed from ‘normal text’ to ‘preformatted text’, the URL becomes broken while the visible text remains the same. For example, test.com has it’s link edited to be http://AGENDA-INSERTION-POINTtest.com.

Can you give me some steps to get this to happen? I tried quickly, putting the cursor in a link in body text paragraph, and changing to preformatted, but in my case it seemed to work fine.

If you can give some steps to get this to happen, it would really help us track it down.

Kind regards,

Sure. If you take this link:
Apply and unapply the preformatted text style, on my end it gets converted to
It doesn’t happen every time and I haven’t been able to identify what exactly makes it happen. But I think the link needs to go in and out formatting style, maybe a few times.

If it helps, I could take a video of the problem.

I tried this myself a few times, and couldn’t get the insertion point text to appear. Perhaps a video is worth trying. Maybe I can see something you are doing that is important to the bug.

Kind regards,

The first link in the video did not produce the issue. The second link inserted “AGENDA” while the third inserted “AGENDA-INSERTION-POINT”.

I am having the same situation when pasting the URL of an OmniFocus project via Shortcuts.

Thanks! I can exactly reproduce the issue by typing the same text. Will look for a fix.

This should have been fixed in the 10.0.3, let us know if you still see this behaviour.