Agenda has claimed ownership of markdown files

I have been running Agenda for a long time… I am guessing over four years now. Recently a small annoyance has cropped up. Agenda has taken over the icon association with markdown files. I first noted this in DevonThink in file lists containing markdown files, but it crops up elsewhere. See the screenshot.

Screenshot 2023-01-11 at 12.26.01 PM

The default programme associated with markdown files is Typora. So if I double click on a file, it properly opens Typora. I have tried uninstalling and installing Typora, but for some reason it will not overwrite that Agenda is associated with these files as my markdown editor.

Has anyone seen this before? It is a minor annoyance, but not how file associations should be managed or associated visually on OSX.

Try locating the relevant md file in Finder, the Cmd I to open Info. There’s something like “open with [app]”. Change that to Typora, and then “Apply to all files of this type“.

Not on Mac right now and haven’t had to do this for years, but something like that!

Yes, follow the advice of @tresbo. Note that Agenda can’t highjack the files itself, so I guess maybe it happened by accident at some point. I have never seen this, in any case. The fix is indeed to use Get Info, and change the app there and apply it to all markdown.

True it did not highjack markdown file, just the icon.

I already tried this.

'Try locating the relevant md file in Finder, the Cmd I to open Info. There’s something like “open with [app]”. Change that to Typora, and then “Apply to all files of this type“

To be fair, this is an osx issue.

Any suggestions?

It is really odd. There is also no way for Agenda to highjack icons of files.

Have you tried just restarting the computer? How about quitting Agenda, searching for all copies of the app Agenda and deleting those (trash and empty trash), and then installing it again. (Note that your data is not stored in the app on macOS, it is elsewhere.)

I did all this and no change. Here is another screenshot of markdown files in DevonThink. The mystery continues!

image

So even if you select on of the files, choose File > Get Info, change the app to TextEdit (or something), then click on the button to apply it to all files, it still doesn’t change it?

Yup, no change. Completely strange.

I’ve never seen something like that. It feels a bit like a corruption of the icon store used by Finder or something. Even if those files were associated with Agenda, there is no reason they should get the Agenda icon. We have other icons for files, whereas what I see there is the Agenda app icon, which should never appear on anything other than the app itself.

Update: Is it possible Obsidian is somehow doing that? If you use Get Info, are the files ending in .md or .markdown? Or is obsidian appending another extension, and then internally setting the icon to the app where the file came from?

Thanks for your patience and support. There is another thread in the DevonThink forums witnessing the same behaviour with Bear’s icon being associated with markdown. The odd thing is that finder still shows a different icon. This is leading me to believe that this is a clash between DevonThink and some notetaking programmes.

Sounds like DevonThink is somehow highjacking that icon process. If Finder is doing it right, it is almost certainly DevonThink changing the icons.

An app icon being hijacked happened to me but it was only for the OmniFocus app, not it’s files. It turned out to be caused by BetterTouchTool and an added extension to OF.

1 Like