Typing format issue after inserting an inline link to another note

What I did: wrote some notes, then inserted a link to another note on the same line.

What happened: when I tried to continue typing after the inserted link, whatever I do the text keeps connected to the hyperlink with a blue color.

  • Tried to change the formatting while I’m still on the same line, like bold, italic…etc still same behaviour.
  • If I click enter to insert a new line, the format on the new line is a default body font and default color. If I go back to the previous line (the one with the link) the issue still exist.
  • However, If I copy a default/normal formatted text from somewhere and paste it after the link, then it return back to the normal font.

What I expected: Back to normal body font, size and color to continue typing.

That’s seems more like a bug to me.

Hmm, what device are you using, and what version of Agenda? Just tried this on the Mac, and it seemed to work as expected for me at least.

Agenda version 13.1.1 (195) - On MacBook Pro (13-inch, M1, 2020, MacOS 12.0.1 (21A559)) installed from App Store.

Ok the issue seems linked to bullet point lists, when inserting a link on a bullet point line the font formatting stuck in the link style.

Maybe other lists (haven’t tried yet) such as number lists…etc.

update

  • Yes other type of lists also have this issue. Number lists, checklists.
  • It only happens to internal links (link to another note), as I can’t replicate the behaviour with external links.

Another related issue
If you click with double finger on trackpad to view the editing menu (for example to insert a link on that line where my cursor is), just after the menu opened the cursor become in highlight/select mode on an empty space and any command, inserting file or link will not get applied.

We will look into the internal link issue. We have some changes coming in Agenda 14 to that.

Do you mean you click at the end of a line, to append something, and instead it selects the rest of the line? If so, that seems to be standard macOS behavior. We don’t do anything special there. You can get a single cursor by tapping right at the end of the line of text, instead of in the space after it.

Drew

my cursor was at the end of “Submitted” line, clicked with double finger on the trackpad and as you see in the picture the it automatically focused on the empty space, the problem if I attach a file or picture or something it doesn’t do it. I don’t think this is a normal behaviour.

OK, thanks for the additional details, we’ll have a look what’s going on.

We’ll see if we can find a better way, but this is really standard macOS behavior. I just tried it in Apple Notes, and it did the same thing. We don’t have any specialized code for that editing.

We will see if we can find a way to avoid it.

Yes they do highlight the empty space but also they do perform the command.

However, in Agenda atm it’s missing the requested action (such as inserting a link to another note) and that is the real problem.

After choosing the Note I want to link to, the menu auto-close and cursor jump into a new line without adding the selected note link.

Ah, OK. I see now. Will look into it.

1 Like