Sync seems unreliable

What I did:

I’m a new user, in general really enjoy the product, but could not get sync working. The sync kind of works, but only partially. Some projects are synced, some are not (tried both with Dropbox and iCloud :see_no_evil:)

What happened:

I set up Agenda on MacOS (I’m a premium user), turned OFF sync and created some categories, added some projects, notes, etc.

A bit later I gave a try to the iOS app. Turned the sync to Dropbox on MacOS. Installed the iOS app, discarded the sample projects after the tutorial, and turned the sync to Dropbox.

Some of my project were synced to the phone, some were not. The categories were also missing. I tried to remove the iOS app, and install it again. When I created something on my phone, I could see that in MacOS, but everything looked really random.

I’ve decided to swith to iCloud. Switched the sync to iCloud on MacOS (deleted data from Dropbox). Did the same on iOS. The result: some other projects were visible, but still not everyting.

Also tried to check previous issues here, and for example logged out from my iCloud account both on iOS and MacOS, deleted the app multiple times, without much luck.

Any help would be appriciated

What I expected:

Sync works

Things that might be helpful to know (Agenda version, OS and model, etc):

MacOS Version 13.1.1 (195) - Paddle (Big Sur)
iOS Version 13.1.1 (iPhone 12 Pro Max 14.6)
I have only 5 projects with 3 categories, and just 4-5 notes per projects

1 Like

Usually, this is simply a case of giving the device enough time to upload/download the data. You could hold Agenda in the foreground for a while, just stopping your device from going to sleep, to give it time. If you don’t want to to have to constantly keep the device from “sleeping”, you can turn off the Autolock in the Settings.

Repeat this on each device, letting it sync for around 20 minutes. Usually that will allow everything to upload and download, and it will be fast after that.

Note that you can see if it is syncing by looking for the cloud icon at the bottom of the right panel. It appears when there is sync activity.

If that doesn’t help, here is what I recommend:

  • Turn off the sync in Agenda on each device.
  • It will ask if you want to remove the cloud data. Do that
  • Wait 10 minutes
  • Now turn on the sync for one of the devices, and let it finish uploading. The cloud will flash in the right panel, or on the window, until it is done. Can take a bit of time, so you might want to disable sleep or autolock
  • Once it is finished, turn on sync for another device, and again wait until finished
  • Repeat for last device.

If this also doesn’t help, I recommend turning off the iCloud switch in System Preferences/Settings app, and then turning it back on again for the same account. Do that on each device.

Thank you for the detailed answer. Doing those exact steps solved my issue.

I tried to do those steps before I write the first message, but what I’ve missed: I did not wait 10 minutes. That seems pretty important, even if I just had some kilobytes of data. Since then, it seems working seamlessly and instantly, even when adding bigger notes.

1 Like

I’m glad it worked! Sorry for the trouble.

1 Like