Removing a date from note does not remove it?

What I did: I am in Today View, with two notes showing up. Opening the note (with todays date assigned) and tapping on „remove date“ does nothing, there ist still today displayed and the note remains in Today View.

What happened:

What I expected:

Things that might be helpful to know (Agenda version, OS and model, etc): iPda Pro 11, latest OS, latest Agenda version.

Thanks

Wolfgang

Same thing on my end as well. Just started using the app and love it…but I figured this was a bug.

Does it get removed if you move away to another project and back again? I think the search index just needs refreshing. It may also be a bit jarring to immediately remove the note as soon as you change the date.

No, sorry, but - no. It simply stays in today!

Wolfgang

Tried it as well: as Wolfgang said, it doesn’t refresh.

OK, thanks. We will investigate this.

Perhaps there is one thing you could try: does it make any difference if you quit/kill the app and launch it again? Is the note still in Today?

Stays in today, even after tapping remove date an force quitting the app!

1 Like

I confirm that this issue exist as of January 27, 2019.

It affects notes with “Today” and future dates.

Example: I have a note with date for “Tomorrow”. I clicked on the Calendar icon in the note, select “Remove Date” and the Calendar pop-up disappear. The note still show “Tomorrow”

Just found out that there’s no “Remove Date” option on the Mac app? This is what I tried:

1). Open a note with “Today” date
2). Click on the small calendar icon
3). The calendar pop-up is shown
4). It show “Assigned to: Today” and “Done”

There was no option to remove the date from the note.

If you tap the calendar icon top-right on the note, you should be able to unselect the date it is attached to, and then click the button bottom-right to commit that change.