Photos taken in Agenda cause crash if moved to Photos app

I added some photos to Agenda notes today by taking a picture. Later I tried to save them to the Photos app and this caused Agenda to crash and the saving to Photos did not occur.

Did it continue to crash each time?

How were you trying to export the photos? Using the “Share” button in the popover?


Yes it did crash every time on my iPhone. I used the share extension not the popover. With the popover (I just tried it) the save image option was not there.
On my MBP running MacOs Mojave it did not crash but the image is in an “unable to upload to iCloud” folder.

Sounds like perhaps it is not an image, but some sort of alias or something.

Any chance you could send a few screenshots showing the files in the sharing extension and in Finder?

Here’s the get info from the photos app in MacOs:

It is in the app but when I log in to icloud on safari the image is not there

I’m a bit confused by the last statement. An image in Agenda will not appear in iCloud. I guess you mean it doesn’t appear in iCloud when you export to Photos app, or to the Files app. Is that right? Are you looking in the right place? Eg. If you export to the Files app, and locate your Documents or Desktop, does it appear there after the export?

Let me back up and describe the exact process - I can see how I made it confusing by mixing platforms and storage etc.
It started when I was at an exhibit at the museum. I want to use Agenda to memorialize the visit including using photos of peieces. Rather than take the photo with the regular camera and importing it into the note I decide to take the photo while in the note. That’s all works fine. Some of the photos I decide I’d like to put into my photos app so using the share sheet I choose save image and this crashes the app. That’s the iphone version. Ios 12.
OK so then I get home and open my MBP. All the photos and notes have synced to Agenda on the mac. I then try to save the image to photos on the Mac. This time it doesn’t crash but it shows in a new folder in the photos app called “Unable to upload to iCloud.” So the photo is in the photos app but only locally. These photos do not appear anywhere else in the apple storage world.
I hope that explains it better.

Thanks, that makes it clear. I will do some testing and see what I can find.

It seems very odd that if the export on the Mac works, that the photos are not in iCloud. Note that the photos app may take a little while to upload the files to iCloud, at which time they should be accessible on your iPhone too. I would be interested to hear if you find that those photos are downloadable in a day or so.

Kind regards,

No its been many days and the two photos are still in the unable to upload to icloud folder in photos.

If you go to the photos app on the device, do you see the photos there? Can you view the image there normallly? What about sharing the photo from Photos app?

Seems like if everything appears normal in Photos, that the problem has to do with syncing of the photos app, rather than Agenda. Once Photos has the image, it should handle uploading to iCloud, not Agenda.

Worth checking your Photos app iCloud settings, and also whether your iCloud is perhaps full.

Perhaps easiest to stick with ios. Remember in ios Agenda crashes when I try to save the image I took in agenda to photos

Will investigate. Thanks!

I hope this isn’t overkill but here are photos of the steps (I was at the gym so forgive the “un-artfullness” of the photo:

/private/var/folders/kt/46l111ys5bl2fz7krhmz5hnh0000gn/T/com.udoncode.copiedmac/Image Copied on 2019-01-04 at 07.52.36 AM.png
Choose camera
/private/var/folders/kt/46l111ys5bl2fz7krhmz5hnh0000gn/T/com.udoncode.copiedmac/Image Copied on 2019-01-04 at 07.53.06 AM.png
Use the share extension
/private/var/folders/kt/46l111ys5bl2fz7krhmz5hnh0000gn/T/com.udoncode.copiedmac/Image Copied on 2019-01-04 at 07.54.18 AM.png
Choose Save Image
Agenda crashes.
I feel like I am being a pain and I guess the easiest thing to do would be to take the photo in the camera app and import it into agenda. My reasoning is that I may tke photos I want to put in my agenda note that I don’t need to have in my photos app and that for those I do I can always go back later and save to my photos app - but that isn’t working.

Thanks for being so responsive.

Thank you, that’s super helpful, we’ll investigate.

Where do those save options come from? I don’t have those on my devices. They don’t seem to be standard options. There is no “Save Image” standard option.

So I guess you have some app that is providing those. Correct?

Same crash for me with iOS. Can capture photo with camera from within App/Note. Single tapping the inserted photo attachment results in a full (iPad Pro) screen (grabbed below). Selecting the arrow in the upper right of the screen brings up the Share sheet with the Save Image option. Crash ensues.

Hmm. Not that I’m aware of. It is supposed to just save the image to It library and in the share extion doesn’t have a toggle to turn it on and off. It’s just there as an option. I’ll dig around a bit more to see if anything else comes up.

Good evening,

I can confirm the App crashing in my iPad, too.

Ah, thanks. Yes, now I can reproduce it. Will investigate.

We have fixed saving of images on iOS. Will be in next release.