One device isn't syncing

What I did: I cloned a drive from one machine to another. It’s signed into iCloud, Agenda has iCloud sync on. My Agenda library appears on the new machine (presumably because the data was already on the drive). I made changes – adding notes, deleting projects, etc.

What happened: Changes don’t sync to / from this new device.

What I expected: Changes sync to / from the device.

Things that might be helpful to know (Agenda version, OS and model, etc):

macOS 10.14.6, Agenda 9.1.2

In the console logs I see

E CloudService.swift(510) : enqueueRemoteUpdateIfNeeded(completionHandler:) : Processing remote updates failed <CKError 0x60000373adf0: "Not Authenticated" (9/1002); "CloudKit access was denied by user settings"; Retry after 3.0 seconds>

I’m not sure how to re-authenticate. I disabled “sync notes with icloud” and re-enabled it, and still get those errors. I disabled syc, quit agenda, launched it, and enabled sync – still get the errors. So I guess I need a way to tell Agenda to try to re-authenticate.

Okay I have a resolution on this: I signed out of iCloud in System Preferences, and signed back in. Agenda is now syncing on this device.

Ah glad to hear that, thanks for letting us know!