Mac Keyboard Shortcuts not recognised

textediting

#1

What I did:
typed a keyboard shortcut (set in System Prefs > Keyboard > Shortcuts)

What happened:
the actual letters I typed appeared in the note

What I expected:
the shortcut to be expanded into the saved text

Things that might be helpful to know (Agenda version, OS and model, etc):


#2

Do you have text replacements enabled?


#3

Yes! Was already enabled.


#4

Is it possible you did that in a preformatted or fixed width part of the text? I think it might be disabled there.


#5

Ok, Something weird going!

Created a new note.

Tried expanding a shortcut in the title - it worked

Tried in the next line.

Created a list and tried - didn’t work

tried on a new line, it didn’t work

Created a new note

Typed some random text

Tried expanding - nope.

Created a new note

Tried expanding in the title - yes

next line - no!

Got bored.

Weird stuff!


#6

The fact that it works in the title is not too weird. The title is a separate text area, and different in many ways to the main text area.

Note that there is one setting for text substitutions in the text editor. Put the cursor in one of them, and check the Edit menu options.

I tested this yesterday, and it did work for me. Let me know if you never see it work, or only sometimes in the text editor part (not title).


#7

It’s not Agenda. It’s Apple - or me plus Apple.

If tried replicating this in other apps and I’ve discovered that the short cut doesn’t expand if you start typing another character before the expanded shortcut is previewed - ie it shows up in a little pop up, like a suggested spelling correction. That explains why the results of my test were so inconsistent.

Now I’ll experiment with some short cuts to tweak how I use Agenda!

Thanks for your help.


#8

so do I understand this correct, there are no shortcuts for agenda? f.E. add Tags, add Person

thanks …


#9

Look in the Note menu. There are shortcuts there for tags and people.

Drew