Creating notes with URLs embedded

What I did:
When I create a new note that I want to leave as is, not converted into markdown and not changed in any way, Agenda converts it anyway and makes it markdown when I copy and paste it elsewhere. I create a note saying something like: This is Google’s URL: I expect it to stay like that so when I copy/paste that later, directly into a browser or into a document, I want it to appear that way.

What happened:
“This is Google’s URL:” is automatically translated to “This is Google’s URL:” Copying the text and pasting it elsewhere pastes in " This is Google’s URL: [ ] ( )." (added spaces so it doesn’t hide what I’m trying to demonstrate)

What I expected:
When entering “This is Google’s URL:”, it is saved as that. When copying and pasting it elsewhere, it pastes in as “This is Google’s URL:” I like the conversion and markdown feature, I just don’t want to use that all the time.

Things that might be helpful to know (Agenda version, OS and model, etc):
MacOS, latest GA version.

This depends on the receiving end of the paste. We put both the rich text and plain text version on the clipboard, the former containing the note as is while the plain text contains the markdown variant. If the receiving end picks the plain text version over the rich text one, you will indeed get the markdown transformation. Unfortunately not something we can easily change as “fixing” it for one use case will do the opposite for others.

I really like using markdown whenever I can. I also like being able to escape that context when I need to as well, such as using the code, > block quote and fenced code block:

fenced code block goes here

Can you add support for at least code and ``` fenced code block notations, per general specifications? Here’s an example of one interpretation of these specs I’m using as reference:

I really like using the Agenda app, but this limitation is a showstopper for me to use Agenda when I need to include code snippets for documentation and general notes.

We will see if we can support fenced ticks in future. Note that you can use three backticks and a space as a way to “turn on” preformatted style. It is not fenced, but it does work as a shortcut to that style.

Kind regards,

Hi @drewmccormack,

Thanks for your response. Per your suggestion, I tried the three backticks and a space to turn on the preformatted style, but it didn’t work. Here’s a brief demo of what I saw:


I think I uncovered what happened. When I use ``` without a following space it worked. Thanks for the tip.

Correct, you need a space after the three tick marks to have them be processed, glad you figured it out already.