After clicking the purchase button, the dialog is stuck

premium

#1

What I did:
I want to purchase the premium feature, so I clicked the purchase button.

What happened:

it stuck at this state.
What I expected:

Things that might be helpful to know (Agenda version, OS and model, etc):
the latest version of Agenda for Mac.


#2

Sometimes this process can take quite a long time, are you sure you have let it spin at least a minute or five? Also, make sure the App Store app is not given an error or asks you to confirm/update anything.


#3

yep, actually it last for more than 10min before I quit the dialogue.


#5

Is it possible that the Mac App Store dialog that should appear was hidden? Eg. if you were in full screen mode, does it help to leave that? Or is another window hiding the purchase dialog from the Mac App Store?


#6

Nope, I was not in full screen mode, and I tried again today, but no good, Maybe I’ll tried it on my iPhone later today after the iOS app debut.


#7

Ok, let us know how you get on, again, apologies for the inconvenience and thank you so much for your willingness to support Agenda!


#8

I have this same issue – let it go for ~20 minutes with no purchase confirmation and I double checked for a hidden confirmation window (and found none). This is with the Mac App Store version of the program. I’m using my personal computer, so I’m not running any VPNs etc, which might be interfering.

Suggestions welcome. Thank you.


#9

A quick update on this – the upgrade purchase never went through with the Mac App store version. When I deleted it and downloaded the version on the website, I was able to purchase the upgrade through PayPal.


#10

Hi Michelle,
Sorry you had this issue. Don’t know what could have been up. The Mac App Store is still a PITA at times.
Thanks for supporting us, and I hope things are well with you and yours.
Drew